1. 打开思科模拟器软件,找出一台2811类的路由器和两台2960类的交换机,4台PC电脑,并用正确的线缆将各个设备互相连接起来,如下图所示:
2.给所有设备都重新命名,路由器命名为r1,一交换机命名为sw1,另一交换机命名为sw2,如下图所示:
3. 先配置路由器r1先,配置命令为:
r1(config)#int f0/0
r1(config-if)#no sh
再配置路由器设备的远程登录和密码保护,配置命令为:
r1(config)#lin vty 0 4
r1(config-line)#login local
r1(config-line)#username admin password cisco
r1(config-line)#exit
r1(config)#enable secret cisco
r1(config)#service password-encrption (此命令为加密所有口令)
如下图所示:
4.配置交换机sw1,配置命令是:
sw1(config)#int vlan 1
sw1(config-if)#ip add 192.168.1.2 255.255.255.0
sw1(config-if)#no sh
sw1(config-if)#ex
sw1(config)#ip default-gateway 192.168.1.1
再用相同方法配置sw2,如下图所示:
5. 配置vlan设定,在sw1上划分vlan 2,3,将相应端口加入其中,配置命令为:
sw1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
sw1(config)#vlan 2
sw1(config-vlan)#ex
sw1(config)#vlan 3
sw1(config-vlan)#ex
sw1(config)#int f0/4
sw1(config-if)#switchport mode access
sw1(config-if)#switchport access vlan 2
sw1(config-if)#int f0/5
sw1(config-if)#switchport mode access
sw1(config-if)#switchport access vlan 3
sw1(config-if)#ex
用相同方法在sw3上面划分vlan,并将相应的端口加入其中,如下图所示:
6.配置单臂路由,实现valn1,2,3之间的互访,配置sw1接口f0/1为主干链路,配置命令是:
sw1(config)#int f0/1
sw1(config-if)#switchport mode trunk
sw1(config-if)#no sh
如下图所示:
7.在路由器r1上进行封装,配置命令如下图所示:
r1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
r1(config)#int f0/0
r1(config-if)#no shut
r1(config)#int f0/0.1
r1(config-subif)#encapsulation dot1Q 1
r1(config-subif)#ip add 192.168.1.1 255.255.255.0
r1(config-subif)#ex
r1(config)#int f0/0.2
r1(config-subif)#encapsulation dot1Q 2
r1(config-subif)#ip add 192.168.2.1 255.255.255.0
r1(config-subif)#ex
r1(config)#int f0/0.3
r1(config-subif)#encapsulation dot1Q 3
r1(config-subif)#ip add 192.168.3.1 255.255.255.0
r1(config-subif)#no sh
r1(config-subif)#ex
如下图所示:
8.配置DHCP服务器,即是配置路由器r1,配置命令是:
r1#enable
r1#conf t
r1(config)#ip dhcp excluded-address 192.168.2.1
r1(config)#ip dhcp pool vlan2
r1(dhcp-config)#net 192.168.2.0 255.255.255.0
r1(dhcp-config)#default-router 192.168.2.1
r1(dhcp-config)#dns-server 100.1.1.2
r1(config)#ip dhcp excluded-address 192.168.3.1
r1(config)#ip dhcp pool vlan3
r1(dhcp-config)#net 192.168.3.0 255.255.255.0
r1(dhcp-config)#dns-server 100.1.1.2
r1(dhcp-config)#ex
9. 现在PC之间可以自动获取IP地址和网关了,如下图所示:
思科DHCP服务器配置实例解析
首先我们应该汇总下我们所需要达到的目标:为服务器提供固定的地址,即做MAC与IP地址的绑定为客户机提供并非固定的地址,通常这会涉及到子网因为我们的实验环境限制,我们先设定第二条,检查下客户机能否得到IP地址,再设置第一条,看看是否按照我们的设定的得到IP地址。那么DHCP服务器配置文件如下:
ddns-update-style interim
ignore client-updates
subnet 192.168.1.0 netmask 255.255.255.0 {
# --- default gateway
option routers 192.168.1.254
option subnet-mask 255.255.255.0
option nis-domain " sky.com"
option domain-name " sky.com"
option domain-name-servers 192.168.1.2
option time-offset -18000# Eastern Standard Time
# option ntp-servers 192.168.1.1
# option netbios-name-servers 192.168.1.1
# --- Selects point-to-point node (default is hybrid). Don't change this unless
# -- you understand Netbios very well
# option netbios-node-type 2
range 192.168.1.100 192.168.1.250
default-lease-time 21600
max-lease-time 43200
}
保存并退出,然后重启dhcpd服务
[root@a ~]# service dhcpd restart
Shutting down dhcpd: [OK]
Starting dhcpd: [OK]
之后我们开启客户端,将客户机网卡设置为DHCP模式,然后我们可以看到客户机的IP地址为192.168.1.250,因为dhcp的.IP地址倒着分发。
将客户机进行ip与MAC的绑定,首先要获知客户机的MAC地址,Windows系统进入CMD,使用getmac命令,linux使用ifconfig可看到。之后我们修改配置文件,完整配置文件如下:
ddns-update-style interim
ignore client-updates
subnet 192.168.1.0 netmask 255.255.255.0 {
# --- default gateway
option routers 192.168.1.254
option subnet-mask 255.255.255.0
option nis-domain " sky.com"
option domain-name " sky.com"
option domain-name-servers 192.168.1.2
option time-offset -18000# Eastern Standard Time
# option ntp-servers 192.168.1.1
# option netbios-name-servers 192.168.1.
telnet和ssh登陆提示
1
# --- Selects point-to-point node (default is hybrid). Don't change this unless
# -- you understand Netbios very well
# option netbios-node-type 2
range 192.168.1.100 192.168.1.250
default-lease-time 21600
max-lease-time 43200
host server2{
hardware ethernet 00:0c:29:47:04:17
fixed-address 192.168.1.2
}
}
之后我们重启DHCP服务
[root@a ~]# service dhcpd restart
Shutting down dhcpd: [OK]
Starting dhcpd: [OK]
重启启用客户机的网卡,service network restart ,之后查看IP信息,这时我们可以看到地址已经变为192.168.1.2
DHCP服务器配置故障排除
1 如果遇见service dhcpd restart/start 无法启动的时候,可以试下:[root@a ~]# /usr/sbin/dhcpd start
如果你的配置文件有错误的话,会出现提示,主要关注的部分为line 之后的
2 修改/etc/sysconfig/dhcpd文件,改变dhcp服务所监听的网口(在多网卡下),在DHCPDARGS=后面添加eth0
3 另外可以关注下/var/lib/dhcpd/dhcpd.leases文件,这里面主要保存的是地址的分发
DHCP服务器配置之防火墙的配置
DHCP服务器主要工作在端口67上监听,然后在端口68上回应客户,所以我们需要配置防火墙,在服务器上面运行:Syetem-config-securitylevel,在other ports里面添加TCP 67 68端口即可,然后启动防火墙,运行service iptables start,然后测试,删除dhcpd.conf配置文件中绑定的部分,之后重启客户机的网卡,检测下能够正确获得到IP地址。
DHCP服务器配置总结
DHCP服务器配置实验至此就结束了,另外分享个技巧,在测试的时候,将2台VM虚拟的linux网卡模式调成Vmnet2模式,那样不会受到干扰。
思科路由器设置方法和常见配置命令
思科路由器怎么设置,是我们经常遇到的问题,下面我准备了关于思科路由器设置方法和常见配置命令,欢迎大家参考学习!
一、基本设置方式
一般来说,可以用5种方式来设置Cisco思科路由器:
1.Console口接终端或运行终端仿真软件的微机
2.AUX口接MODEM,通过电话线与远方的终端或运行终端仿真软件的微机相连
3.通过Ethernet上的TFTP服务器
4.通过Ethernet上的TELNET程序
5.通过Ethernet上的SNMP网管工作站。
但Cisco思科路由器的第一次设置必须通过第一种方式进行,一般用超级终端通过com口进行控制。此时终端的硬件设置如下:
波特率 :9600
数据位 :8
停止位 :1
奇偶校验: 无
二、命令操作
Cisco思科路由器所用的操作系统是IOS.共有以下几种状态:
1、router>
在router>提示符下,Cisco思科路由器处于用户命令状态,这时用户可以看Cisco思科路由器的连接状态,访问其它网络和主机,但不能看到和更改Cisco思科路由器的设置内容。此时输入?并回车,可以查看到在此状态下可以用的命令。(IOS允许你在任何时候用这种方式查看在某种状态下可以用的命令)。在敲入enable并回车后,按照系统提示输入密码,(在新的Cisco思科路由器第一次进行调试的时候不需要输入密码,直接回车即可)进入#提示符,就可以对Cisco思科路由器进行各种操作了。
2、router#
Cisco思科路由器进入特权命令状态router#后,不但可以执行所有的用户命令,还可以看到和更改Cisco思科路由器的设置内容。此时就可以对Cisco思科路由器的名字、密码等进行设置。
3、router(config)#
在router#提示符下键入configure terminal,出现提示符router(config)#,此时Cisco思科路由器处于全局设置状态,这时可以设置Cisco思科路由器的全局参数。
4、router(config-if)#
router(config-line)#
router(config-router)#…
Cisco思科路由器处于局部设置状态,这时可以设置Cisco思科路由器某个局部的参数。
5、Cisco思科路由器处于RXBOOT状态,在开机后60秒内按ctrl-break可进入此状态,这时Cisco思科路由器不能完成正常的功能,只能进行软件升级和手工引导。在此状态下,可以进行口令恢复。
三、常用命令
1.帮助
在IOS操作中,无论任何状态和位置,都可以键入“?”得到系统的帮助。系统会显示此时可以使用的命令。
2.改变命令状态
任务命令
进入特权命令状态enable
退出特权命令状态disable
进入设置对话状态Setup
进入全局设置状态config terminal
退出全局设置状态End
进入端口设置状态interface type slot/number
进入子端口设置状态interface type number.subinterface [point-to-point | multipoint]
进入线路设置状态line type slot/number
进入路由设置状态router protocol
退出局部设置状态Exit
3.显示命令
任务命令
查看版本及引导信息show version
查看运行设置show running-config
查看开机设置show startup-config
显示端口信息show interface type slot/number
显示路由信息show ip router
4.拷贝命令
用于IOS及CONFIG的备份和升级
5.网络命令
任务命令
登录远程主机telnet hostname|IP address
网络侦测ping hostname|IP address
路由跟踪Trace hostname|IP address
6.基本设置命令
任务命令
全局设置config terminal
设置访问用户及密码username username password password
设置特权密码enable secret password
设置Cisco思科路由器名hostname name
设置静态路由ip route destination subnet-mask next-hop
启动IP路由ip routing
启动IPX路由Ipx routing
端口设置interface type slot/number
设置IP地址ip address address subnet-mask
设置IPX网络Ipx network network
激活端口no shutdown
物理线路设置line type number
启动登录进程login [local|tacacs server]
设置登录密码password password
本文描述了如何进行思科路由器的基本设置,基本的命令操作以及常用命令进行操作和总体的.设置,并讲述了一些基本的服务设置。
四、总体设置
在router#特权命令状态下,可以用setup对Cisco思科路由器进行总体设计,利用这个设计过程可以省略手工设置的烦琐。但它还不能完全代替手工设置,一些特殊的设置还必须通过手工输入的方式完成。
进入设置对话过程后,Cisco思科路由器首先会显示一些提示信息:
--- System Configuration Dialog ---
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
这是告诉你在设置对话过程中的任何地方都可以键入“?”得到系统的帮助,按ctrl-c可以退出设置过程,缺省设置将显示在‘[]’中。然后Cisco思科路由器会问是否进入设置对话:
Would you like to enter the initial configuration dialog? [yes]:
如果按y或回车,Cisco思科路由器就会进入设置对话过程。首先你可以看到各端口当前的状况:
First, would you like to see the current interface summary? [yes]:
Any interface listed with OK? value "NO" does not have a valid configuration
InterfaceIP-AddressOK?MethodStatusProtocol
Ethernet0unassignedNOunsetupup
Serial0unassignedNOunsetupup
……………………………
然后,Cisco思科路由器就开始全局参数的设置:
Configuring global parameters:
1.设置Cisco思科路由器名:
Enter host name [Router]:
2.设置进入特权状态的密文(secret),此密文在设置以后不会以明文方式显示:
The enable secret is a one-way cryptographic secret used
instead of the enable password when it exists.
Enter enable secret: cisco
3.设置进入特权状态的密码(password),此密码只在没有密文时起作用,并且在设置以后会以明文方式显示:
The enable password is used when there is no enable secret
and when using older software and some boot images.
Enter enable password: pass
4.设置虚拟终端访问时的密码:
Enter virtual terminal password: cisco
5.询问是否要设置Cisco思科路由器支持的各种网络协议:
Configure SNMP Network Management? [yes]:
Configure DECnet? [no]:
Configure AppleTalk? [no]:
Configure IPX? [no]:
Configure IP? [yes]:
Configure IGRP routing? [yes]:
Configure RIP routing? [no]:
………
6.如果配置的是拨号访问服务器,系统还会设置异步口的参数:
Configure Async lines? [yes]:]
1)设置线路的最高速度:
Async line speed [9600]:
2)是否使用硬件流控:
Configure for HW flow control? [yes]:
3)是否设置modem:
Configure for modems? [yes/no]: yes
4)是否使用默认的modem命令:
Configure for default chat script? [yes]:
5)是否设置异步口的PPP参数:
Configure for Dial-in IP SLIP/PPP access? [no]: yes
6)是否使用动态IP地址:
Configure for Dynamic IP addresses? [yes]:
7)是否使用缺省IP地址:
Configure Default IP addresses? [no]: yes
是否使用TCP头压缩:
Configure for TCP Header Compression? [yes]:
9)是否在异步口上使用路由表更新:
Configure for routing updates on async links? [no]: y
10)是否设置异步口上的其它协议。接下来,系统会对每个接口进行参数的设置。
1.Configuring interface Ethernet0:
1)是否使用此接口:
Is this interface in use? [yes]:
2)是否设置此接口的IP参数:
Configure IP on this interface? [yes]:
3)设置接口的IP地址:
IP address for this interface: 192.168.162.2
4)设置接口的IP子网掩码:
Number of bits in subnet field [0]:
Class C network is 192.168.162.0, 0 subnet bitsmask is /24
在设置完所有接口的参数后,系统会把整个设置对话过程的结果显示出来:
The following configuration command script was created:
hostname Router
enable secret 5 $W5Oh$p6J7tIgRMBOIKVXVG53Uh1
enable password pass
…………
请注意在enable secret后面显示的是乱码,而enable password后面显示的是设置的内容。就是说,secret密码的优先级比较高,在两个密码都设了的情况下,secret密码起作用。
显示结束后,系统会问是否使用这个设置:
Use this configuration? [yes/no]: yes
如果回答yes,系统就会把设置的结果存入Cisco思科路由器的NVRAM中,然后结束设置对话过程,使Cisco思科路由器开始正常的工作。
五、广域网协议设置
PPP
PPP(Point-to-Point Protocol)是SLIP(Serial Line IP protocol)的继承者,它提供了跨过同步和异步电路实现Cisco思科路由器到Cisco思科路由器(router-to-router)和主机到网络(host-to-network)的连接。
CHAP(Challenge Handshake Authentication Protocol)和PAP(Password Authentication Protocol) (PAP)通常被用于在PPP封装的串行线路上提供安全性认证。使用CHAP和PAP认证,每个Cisco思科路由器通过名字来识别,可以防止未经授权的访问。
任务命令
设置PPP封装encapsulation ppp1
设置认证方法ppp authentication {chap | chap pap | pap chap | pap} [if-needed] [list-name | default] [callin]
指定口令username name password secret
设置DCE端线路速度clockrate speed
欢迎分享,转载请注明来源:夏雨云
评论列表(0条)